Canon LBP5050n “Network Board Error”

This has been a continuing problem since I got this printer: our Canon LBP5050n network printer only works occasionally, throwing up “network board error” messages when used under Windows 7. All documents, web pages etc. first have to be opened in our Windows Server 2008 (or my netbook, with Windows 7 Starter edition and Wifi connection), where printing goes fine. I have been changing router settings, putting the printer into different configurations, but nothing seems to be helping. It might be that this is caused by the complex network topology (there are several routers in our home network), but it is still curious that sometimes I manage to print a page from even these Windows 7 workstations, but then, quickly, the damn error message comes up again and the network connection to the printer is apparently lost again. Most annoying.

Author: frans

Professor of Information Studies and Interactive Media, esp. Digital Culture and Game Studies in the University of Tampere, Finland.

21 thoughts on “Canon LBP5050n “Network Board Error””

  1. After a couple of more days of debugging, I think I might have cracked finally this issue. As I understand it, 5050n was getting its IP from a local router downstairs, while it should have been fixed to an IP set by our main router upstairs. I changed the setting in CAPT printer window – Options – Device Settings – Network Settings. I did put the TCP/IP setting into “Auto Detect” and ticked option for DHCP. Then I used the web interface of our main router (which acts as the DHCP server for our home) to fix the MAC address of 5050n into a fixed IP. Then what was left was to delete the installation of printer driver from all the workstations / laptops (in some cases this was also tricky, since you could not uninstall the printer if there were print jobs in the queue — you needed to first manually stop the printer spooler service, then go to Windows’ system32-spooler job directory, delete everything from there, and then, after restarting the spooler service, proceed with the uninstallation). After this it was possible to reinstall the CAPT printer driver and make it redetect the printer in the new (hopefully more permanent/problem-free) IP address. Not to mention that to get some of these steps to work, you first needed to realize that an external firewall software was also making it impossible for the installer to find the IP for the printer.

    To conclude, home networking is still, after all these years, in a messy and complex state where infinite patience and trial-and-error method is needed. Supposedly user-friendly innovations such as “homegroup” of Windows 7, or DLNA (Digital Living Network Alliance) specification are trying to simplify home connectivity, but my experience tells that we are still far from the state where things would “just work”. Admitted, our home is probably a bit more complex environment than most, and the fact that we have a largish number of IP devices set up to share several subnets (due to small number of physical cables that go through the walls), and two Wifi subnets on top of that, causing some extra challenge. But: homes are messy by definition. They are environments built up by historical layers of different elements, some of them contemporary hi-tech, some not so. Robust interoperability is a must in this kind of setting. Lack of that — the present reality — is real pain.

  2. The final non-printing PC is now also connected. The most conflicting one was my main workstation, which had some serious issues in keeping connection to 5050n. Finally the only solution that I came up with involved unplugging the damn machine from the wired ethernet completely, and installing a Wifi network card into it. That way, it was no longer in the dark about the subnet where 5050n was lurking, and could use wireless connection to it instead. The downside is that wired connection was faster when large file operations were concerned. It is perhaps best to disable and re-enable the wired connection on-demand-basis, manually. Yes I know, it is not a pretty solution, but the best one I could come up with right now.

  3. I recently got the LBP 6300dn Laser and had similar issues. I initially had 1 router which was wireless and a switch to connect a wired pc and the printer in another location, both via Ethernet. was having major problems as when the printer went idle it would not show up as connected. so got rid of the switch and connected laser printer to the router. same problem.
    After lots of trial an error I think I have found a FIX!!!
    go into devices and printers then right click the printer to get printer properties. go to the ports tab and click on configure port. Then disable “SNMP status enabled” at the bottom and thats it! been running my laser printer now only connected via Ethernet for a few hours now and no disconnection!

  4. Sameer, thanks for the tip. It has taken me a few days to get into testing it, and unfortunately it now looks like that the same solution does not work in my case. I did set the port configuration into SNMP status disabled, but I still get the Network Board Error message if I am connected to the same subnet as the printer. It is possible to print using a workaround where you have another computer in the LAN set up to share the Canon printer to the HomeGroup, so that I can print through it. This is a bit silly though: I am physically sitting next to the printer but can only print to it by having another computer running in another room upstairs.

  5. Hi, have the same problem. Is there a way how to print a network status of the printer without printer drivers (like holding some buttons when starting as known from other printers?)

  6. This has been a problem for me also. It was working, I changed router, it stopped working with the network board error. Changed the port and nothing. Removed and reinstalled, still same error. Eventually I found the problem …. Windows fire wall. I disabled it and the error went away and let me print across the network. I then turned the firewall back on and the error came back. I then looked into the firewall settings and it seems there was loads of entries for the printer, some allowed some blocked. I allowed them all and it works fine now. Simple things sometimes elude us.

  7. Thanks for the note, Alan. I took a look, and yes, also I had many entries (34 of them) for “Canon CAPT Port” in the Windows Firewall “Inbound Rules” section. Nothing in the Outbound part, though, and in my case all the inbound rules were also allowed. Thus, I am not sure if the firewall was the cuprit in my case, but thanks for the suggestion, I will explore this option further later.

  8. I tried this out now, and it appears that I probably have a different kind of problem: switching off the firewall does not make any change, the “Network Board Error” remains even while firewall is off. Weird. The only way I am able to print currently is via another computer that is at another subnet — that computer has a reliable connection to LBP5050n, and after sharing that one to the homegroup, I can print via that shared printer, rather than trying to do it directly from this computer.

  9. I’ve been having same issues with 5050n, but for me the solution is completely different: I have to disable VirtualBox Host Only Network adapter, and then printing works. You might want to check this if you use any virtual machine software.

    Canon driver is seemingly bad at resolving route to the printer.

  10. Tero, thanks for the tip. I have also been using a virtual machine in this workstation, so I thought there might indeed be a connection here, too. Unfortunately there have been some connection errors also after I uninstalled the virtual machine software, so it might be that in my case there are some other problems.

  11. Hi Frans

    Have you found a answer to this problem?? I am a printer field service engineer for Canon UK (sub contracted) and I have 2 LBP5050’s with the same problem, both printers have had there network boards swapped but still getting “network board error”. I 100% say that one of the printers is using windows 7 software.

    Canon reckon that there is no software/printer problems must be something to do with the customers network. But im not believing what they are saying.

  12. I had the same problems on a small business network. IP just came up as 192.168.0.215. would constantly give Network Board Errors. I had made a DHCP reservation on the server, but the device just didnt show up in DHCP console. I then found this article:

    http://www.canon.co.uk/Support/Consumer_Products/products/printers/Laser/i-SENSYS_LBP6300dn.aspx?faqtcmuri=tcm:14-707049&page=1&type=faq

    It uses NetSpot to specify the IP of the printer. …it seems that the printer didnt come network configured ….i.e DHCP was not enabled. i followed the steps for “not configured” and set “IP address settings” to DHCP. the server then picked up the device reservation in DHCP and all was fine. didnt need to uninstall the printer software from each pc, just went into printer port properties and changed the port number to what i had made it in the reservation.

    If you dont have a server, then you could make a reservation for the printer in your router, using the printers MAC address.

    hope this helps! 🙂

  13. I had the same problems with a Canon LBP5360 (Network Board Errors) with the same issues: the detection tool would find the printer (manual ip address in the printer) and the Driver installation package from the website could not find the printer. I could access the printer through the website; http://ipaddress. But i would get network board errors, saying my printer was disconnected… My solution was to remove the whole darned thing (including the detection software and the rpinter and the drivers)
    I reinstalled the printer as a local printer via the add printer wizard in windows 7, made a standard TCP/IP port and i used the Windows 7 drivers.

    now it works like a charm.

    Cheers, Sam

  14. For me it was the firewall, added the some exceptions for all the canon applications and that worked. the canon applications are at:

    C:\Windows\System32\spool\drivers\w32x86\3
    CNAC8SWK.exe
    CNAC8UN.exe
    CNAP2LAK.exe
    CNAP2RPK.exe
    CPC10DAE.exe
    CPC10QAE.exe
    CPC10VAE.exe

  15. Constantly happens to me whenever the router re-assigns a new IP address to the printer. The only way I have been able to fix it (apart from assigning a permanent IP address) is to use NetSpot installer (from Canon, on the installation CD) to delete the device and then re-detect it.

  16. I had this problem with my LBP5050N Here’s what I did to solve Problem.
    I threw everything at it so I don’t know exactly what fixed it.

    Reset the network board (little hole above RJ45 socket)
    set the ip using the arp -s mac address command from the cmd
    Setup DHCP reservation for printer
    Went into the Remote UI and changed the network setting to DHCP On
    disabled SNMP
    added port 9100 to the firewall exceptions on client computer.

    I’d say disabling the SNMP in the Remote UI and on the Ports section of the Driver properties did the trick!

    Thanks for all the help above, I would of been at sea.
    Would of probably sent the printer back for an RMA too.

    1. Hi Michael,

      Thanks for sharing your experiences – hopefully most people will eventually be able to use this printer – for printing. 🙂

  17. I tried turning off Windows Firewall, and I could then get at the printer. I added an inbound firewall rule to allow TCP to local port 9100, turned the firewall on and it’s still working for me.

  18. Regarding problem with network and canon LBP 5050n.
    The way to do it is, download software to LBP5050n from Canon Homepage.Install the software and let the software find your printer.
    When your computer needs to restart disconect your printer. When your computer is restarted connect your printer to the network and Windows firewall will see your printer and make an exception through the firewall.
    Now you are up and running with your new printer.

  19. I reached here looking for solution to similar problem printing to Canon LBP3300 on Windows 8. The printer was working fine on Win 7 Pc’s and Mac’s but not windows 8.

    I was getting this error “The network cable is not connected, or the printer is not turned on. Check these items.”

    The problem was solved by creating a custom firewall rule in Windows Firewall Advanced Settings menu allowing all communication to the printer’s IP address.

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s